n1ro°
RU

Ошибки · Решение

SQL Server ошибка 3187: что означает и как исправить

RESTORE запущен с требованием checksum, но в выбранной резервной копии нет соответствующей checksum-информации.

Редакция N1RO · Проверено

Короткий ответ

Код 3187 возникает, когда RESTORE WITH CHECKSUM применяют к backup, в котором checksum-информации нет. Либо используйте подходящий backup с checksum, либо не требуйте отсутствующую проверку.

Что означает ошибка

RESTORE запущен с требованием checksum, но в выбранной резервной копии нет соответствующей checksum-информации.

Возможные причины

  • Политика backup раньше не включала checksum.
  • RESTORE command требует проверку, которой этот старый набор не поддерживает.
  • Backup создан без checksum-информации.

Что проверить

  • Проверьте, есть ли альтернативная копия с checksum.
  • Проверьте свойства backup через `RESTORE HEADERONLY`.
  • Убедитесь, что выбран правильный файл, а не более старый backup.

Безопасные шаги

  1. Для текущего восстановления используйте только допустимые options для этого backup.
  2. Для будущих backup пересмотрите политику `WITH CHECKSUM`.
  3. Отсутствие checksum не считайте доказательством целостности данных.

Только безопасные обратимые действия. Опасные шаги — только по официальной инструкции и с пониманием рисков.

Когда нужен сервис

  • Если SQL Server 3187 повторяется после проверки указанного состояния, передайте DBA полный текст ошибки, несколько соседних записей SQL Server error log, версию/edition, имя базы и точную команду, на которой возник сбой.

Похожие ошибки

  • /errors/sql-server-error-3002/
  • /errors/sql-server-error-3013/
  • /errors/sql-server-error-3021/

Что учитывать

Точная причина зависит от версии ПО/прошивки, полного текста ошибки и контекста. Официальная инструкция имеет приоритет.

Официальный источник

Расшифровка сверена с официальными страницами поддержки из источников ниже. Редакция N1RO не диагностировала ваш конкретный случай.